WhoSubscribed - Cloudflare Workers deployment Issues – Incident details

All systems operational

Cloudflare Workers deployment Issues

Resolved
Degraded performance
Started 2 days agoLasted about 1 hour

Affected

Cloudflare

Operational from 1:56 AM to 3:03 AM

Workers

Operational from 1:56 AM to 3:03 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Identified
    UTC
    Identified

    The issue has been identified and a fix is being implemented.

  • Investigating
    UTC
    Investigating

    Cloudflare is aware that deploying Workers that the nodejs_compat compatibility flag and a compatibility date on or after 2026-08-04 is being disallowed. This is impacting Workers and Workers for Platforms.

    We are working on relaxing this assertion. To avoid this error, remove the nodejs_compat compatibility flag from your Worker.